Правильная блокировка сайта vk.com (ВКонтакте) на MikroTik

1079893_v01_b

Здравствуйте уважаемые читатели. Недавно в интернете я подсмотрел способ блокировать сайты на MikroTik не нагружая процессор. Им сегодня я и поделюсь.

Способ хорош как для малых сетей так  и для предприятий. Используем принцип:

/ip firewall address-list
add list=Site-VK address=vk.com
add list=Site-VK address=www.vk.com
add list=Site-VK address=userapi.com
add list=Site-VK address=pp.userapi.com

/ip firewall filter
add chain=forward out-interface=ether1 dst-address-list=Site-VK protocol=tcp action=reject reject-with=tcp-reset
add chain=forward out-interface=ether1 dst-address-list=Site-VK action=drop

Первым режектом вы обрубаете коннект, мгновенно сбросив таймаут до нуля и тут же дропаете следующий запрос.

Правила нужно прописывать через терминал, так как ручное добавление доменов в Address List не даёт правильных результатов.

P.S. Есть один недостаток: Блокировку можно обойти подключившись к сайту через внешний прокси сервер.